MikroTik - Настройка L2TP/IPSEC

Задача настроить MikroTik для подключения IOS и прочих операционных систем, причем выбрать унифицированную конфигурацию.

PPTP клиента из IOS IPhone и Windows Phone выпилили, так как во время авторизации пароль передаётся в зашифрованном виде des, а данный протокол шифрования был скомпрометирован и на текущих домашних мощностях подобрать ключ можно менее чем за сутки.

Выбор пал на связку L2TP/IPSEC – поддерживается почти всем оборудованием, даже мамонт Windows XP его поддерживает из коробки.

Сразу оговорюсь так как мы мудим настраивать унифицированную конфигурацию, то мы не будем использовать последних фичь, для упрощения настройки, а сделаем всё руками.

И так присупим

Создадим группу


/ip ipsec policy group add name=l2tp
    

Создадим proposal


/ip ipsec proposal add enc-algorithms=aes-256-cbc,aes-128-cbc name=L2TP pfs-group=none
    

Создадим шаблон политик IPSec


/ip ipsec policy add dst-address=0.0.0.0/0 group=l2tp proposal=L2TP src-address=0.0.0.0/0 template=yes
    

Создадим IPSec peer


/ip ipsec peer add enc-algorithm=aes-256,aes-192,aes-128,3des exchange-mode=main-l2tp generate-policy=port-strict passive=yes policy-template-group=l2tp secret=mysecretkey
    

Теперь вам необходимо настроить ваш любимый L2TP сервер и создать авторизацию, либо локально, либо через radius.

Не забудьте со стороны провайдера разрешить для IPSec UDP порты 500 и 4500

Контакты

vasilevkirill.com
г. Санкт-Петербург
Т:+7 (905) 207-3578
Мы работаем ежедневно с 10:00 до 18:00
Васильев Кирилл
me@vasilevkirill.com